Postal services might have some issues
Incident Report for WebWave
Resolved
This incident has been resolved.
Posted Nov 26, 2020 - 08:14 CET
Monitoring
We highly suggest using mail.webwavecms.com
Posted Nov 26, 2020 - 08:11 CET
Identified
Some users wont be able to send an attachment or have troubles sending a message.
Posted Nov 25, 2020 - 11:14 CET
This incident affected: Webmail client.